Open Shortest Path First (OSPF), Primer Camino Más Corto, es un protocolo de red para encaminamiento jerárquico de pasarela interior o Interior Gateway Protocol (IGP), que usa el algoritmo SmoothWall Dijkstra enlace-estado (Link State Advertisement, LSA) para calcular la ruta idónea entre dos nodos cualesquiera de un sistema autónomo.

Su medida de métrica se denomina cost, y tiene en cuenta diversos parámetros tales como el ancho de banda y la congestión de los enlaces. OSPF construye además una base de datos enlace-estado (Link-State Database, LSDB) idéntica en todos los routers de la zona.

Mapa de red

mapa de red ospf

 

Ejemplo configuración router 1

Uso de los comandos

Enable ==> Accede a los privilegios de administración

Configure terminal ==> Accede a las interfaces de configuración

Int ==> Accede a la interfaz de red seleccionada para configurarla

No shutdown ==> Enciende la tarjeta de red


Router enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#int s0/0/0
Router(config-if)#ip address 10.1.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#int s0/0/1
Router(config-if)#ip address 10.2.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#int s0/1/0
Router(config-if)#ip address 10.5.0.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#

Generando el routing OSPF en el router 1

Uso de los comandos

Dentro de la administración del router se aplican los comandos:

router ospf 1 ==> Especifica el tipo de routeo a usar y el process ID (Debe ser el mismo en todo el anillo de redes adyacentes).

network 10.1.0.0 0.0.0.255 ==> Especifica la red adyacente y su máscara wildcard.

Las máscaras wildcard son las inversas a las de red;

para una máscara 255.255.255.0 ==> 0.0.0.255


Router enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 10.1.0.0 0.0.0.255 area 1
Router(config-router)#network 10.2.0.0 0.0.0.255 area 2
Router(config-router)#network 10.5.0.0 0.0.0.255 area 3
Router(config-router)#

Securización OSPF en el router 1

El simulador de redes Packet tracer no permite ejecutar estas opciones con los routers por defecto, pero lo vamos a explicar igualmente.

Uso de los comandos

area 1 authentication message-digest ==> Especifica que el área 1 estará cifrado.

int ==> Especifica la interfaz que se va a proceder a cifrar.

ip ospf message-digest-key 1 md5 password ==> Especifica el número de clave (1) y la password (password).
ip ospf authentication message-digest ==> Especifica que se active la conexión cifrada.

 


Router enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 10.1.0.0 0.0.0.255
% Incomplete command.
Router(config-router)#network 10.1.0.0 0.0.0.255 area 1
Router(config-router)#network 10.2.0.0 0.0.0.255 area 2
Router(config-router)#network 10.5.0.0 0.0.0.255 area 3
Router(config-router)#area 1 authentication message-digest
Router(config-router)#area 2 authentication message-digest
Router(config-router)#area 3 authentication message-digest

Router(config-router)#int s0/0/0
Router(config-if)#ip ospf message-digest-key 1 md5 password
Router(config-if)#ip ospf authentication message-digest

Router(config-if)#int s0/0/1
Router(config-if)#ip ospf message-digest-key 1 md5 password
Router(config-if)#ip ospf authentication message-digest

Router(config-if)#int s0/1/0
Router(config-if)#ip ospf message-digest-key 1 md5 password
Router(config-if)#ip ospf authentication message-digest
Router(config-if)#

Anuncios