EIGRP (Protocolo de Enrutamiento de Puerta de enlace Interior Mejorado en español) es un protocolo de encaminamiento vector distancia avanzado, propiedad de Cisco Systems, que ofrece lo mejor de los algoritmos de vector de distancias y del estado de enlace.

Mapa de red

mapa de red

Ejemplo configuración router 1

Uso de los comandos

Enable ==> Accede a los privilegios de administración

Configure terminal ==> Accede a las interfaces de configuración

Int ==> Accede a la interfaz de red seleccionada para configurarla

No shutdown ==> Enciende la tarjeta de red


Router enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#int s0/0/0
Router(config-if)#ip address 10.1.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#int s0/0/1
Router(config-if)#ip address 10.2.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#int s0/1/0
Router(config-if)#ip address 10.5.0.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#

Generando el routing EIGRP en el router 1

Uso de los comandos

Dentro de la administración del router se aplican los comandos:

router eigrp 20 ==> Especifica el tipo de routeo a usar y el process ID (Debe ser el mismo en todo el anillo de redes adyacentes).

network 10.1.0.0 0.0.0.255 ==> Especifica la red adyacente y su máscara wildcard.

Las máscaras wildcard son las inversas a las de red;

para una máscara 255.255.255.0 ==> 0.0.0.255


Router enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router eigrp 20
Router(config-router)#network 10.1.0.0 0.0.0.255
Router(config-router)#network 10.2.0.0 0.0.0.255
Router(config-router)#network 10.5.0.0 0.0.0.255
Router(config-router)#

Securización EIGRP en el router 1

El simulador de redes Packet tracer no permite ejecutar estas opciones con los routers por defecto, pero lo vamos a explicar igualmente.

Uso de los comandos

key chain ==> Genera el llavero donde se almacenarán las claves (En este caso llaves).

key  ==> Especifica el número de llave dentro del llavero (En este caso el 2).

key-string ==> Especifica la password(caracoles) de la llave (2) del llavero (llaves).

int ==> Especifica la interfaz a la cual se le aplicará el cifrado.

ip authentication mode eigrp 20 md5 ==> Especifica que el proceso de cifrado se vincula al routero eigrp del process ID 20 y será md5.

ip authentication key-chain eigrp 20 llaves ==> Especifica que la password está almacenada en el routeo eigrp con el process ID 20 dentro del llavero llaves.


Router enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#key chain llaves

Router(config)#key 2

Router(config)#key-string contrasena

Router(config)#int s0/0/0

Router(config)#ip authentication mode eigrp 20 md5

Router(config)#ip authentication key-chain eigrp 20 llaves

Router(config)#int s0/0/1

Router(config)#ip authentication mode eigrp 20 md5

Router(config)#ip authentication key-chain eigrp 20 llaves

Router(config)#int s0/1/0

Router(config)#ip authentication mode eigrp 20 md5

Router(config)#ip authentication key-chain eigrp 20 llaves

Visualizar todos los vecinos en routeo eigrp


ip eigrp neighbors

Anuncios